AppFuse
  1. AppFuse
  2. APF-1116

Synch with latest tapestry5-appfuse

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.1.0-M1
    • Component/s: Web - Tapestry
    • Labels:
      None

      Description

      Initial work done by Serge Eby:

      http://markmail.org/message/cjeslecr5a3bfvzw

        Activity

        Serge Eby created issue -
        Serge Eby added a comment -

        Please find included patch to latest version 1.0.1.

        3 rejects needs to be overridden with latest code:

        ./src/main/java/org/appfuse/webapp/pages/PasswordHint.java
        ./src/main/java/org/appfuse/webapp/pages/Logout.java
        ./src/main/java/org/appfuse/webapp/pages/admin/UserList.java

        These 2 files were moved to a new package:
        src/test/java/org/appfuse/webapp/pages/BasePageTester.java
        src/test/java/org/appfuse/webapp/pages/BasePageTestCase.java

        See change details in CHANGELOG.txt file:

        http://code.google.com/p/tapestry5-appfuse/source/browse/tags/RELEASE_1.0.1/CHANGELOG.txt

        Serge Eby made changes -
        Field Original Value New Value
        Attachment t5appfuse_1.0.1.patch [ 10514 ]
        Matt Raible added a comment -

        Would it be possible to create a patch against the latest code in AppFuse's trunk?

        svn co https://appfuse.dev.java.net/svn/appfuse/trunk --username guest

        password is blank

        I managed to get all your 1.0 changes in yesterday. Things I changed:

        1. Moved BasePage from "base" package to "pages" package. This is what we use for all other web frameworks, so it seems to make sense.
        2. Turned on client-side validation in forms. Unfortunately, messages show up all left-aligned, but I'm sure some CSS or JS can fix that.
        3. Modified web-tests.xml to get Canoo Web Tests passing.
        4. Changed FileDisplay.java to use individual properties instead of UploadedFile. UploadedFile is not Serializable and that was causing issues with Canoo Web Test.
        5. Fixed Login page so CSS is included to center the box.
        6. Fixed login.js so works and doesn't have unprocessed <fmt:message> tags. Client-side validation doesn't work on login, would be nice if we could get that working.
        7. Fixed PasswordHint so it works properly and passes Canoo Web Tests.
        8. Added rule to urlrewrite.xml so login.jsp redirects to login. This is caused by menu.jsp and is shared by all web frameworks. This should become less of an issue when we move to extension-less URLs for all frameworks.

        Matt Raible added a comment -

        Serge - do you have a simple CRUD example I can look at for Tapestry 5? I need to modify all the AMP FreeMarker Templates for Tapestry 5. You can view them via FishEye at:

        http://tinyurl.com/66qrvf

        Thanks,

        Matt

        Matt Raible made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Matt Raible
            Reporter:
            Serge Eby
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development