AppFuse
  1. AppFuse
  2. APF-936

BaseDaoTestCase#populate( Object ) does not work

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0 Final
    • Fix Version/s: 2.1.0-M1
    • Component/s: Tools - AppGen
    • Labels:
      None
    • Environment:
      Maven version: 2.0.7
      Java version: 1.5.0_11
      OS name: "linux" version: "2.6.20-16-generic" arch: "i386"

      Description

      BaseDaoTestCase#populate( Object ) uses spring-2.0.6's BeanUtils.copyProperties( HashMap, Object ). However, I think the first parameter of copyProperties(...) should have the same properties of the 2nd parameter for it to work properly.

        Activity

        Anil Gangolli added a comment -

        I am seeing this in 2.0.2

        The problem is that the call to BeanUtils.copyProperties is reversed. The destination is supposed to be the first parameter, the second is supposed to be the source.

        The call at BaseDaoTestCase:76 should be

        BeanUtils.copyProperties(obj, map);

        Anil Gangolli added a comment -

        This is a patch based on the version of org.appfuse.dao.BaseDaoTestCase in appfuse-hibernate-2.0.2.jar

        Anil Gangolli added a comment -

        Hey! There's no way to reopen issues !?

        Matt Raible added a comment -

        Thanks for the patch!


          People

          • Assignee:
            Matt Raible
            Reporter:
            Franz Allan Valencia See
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development