Struts Menu
  1. Struts Menu
  2. SM-79

Same duplicate names do not show up properly

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.4.3
    • Component/s: Displayers
    • Labels:
      None
    • Environment:
      Windows, Unix

      Description

      In case of the following tree structure:

      Root
      Marketing_Information
      Images
      Image1.jpg
      Image2.jpg
      Image3.jpg
      Brochures
      Borchure1.jpg
      Borchure2.jpg
      Samples
      Sample1.txt
      Sample2.txt
      Sample3.txt
      Personal_Information
      Images
      Image3.jpg
      Image4.jpg
      Image4.jpg
      Brochures
      Borchure3.jpg
      Borchure4.jpg
      Assets
      Assets1.doc
      Assets2.doc
      Assets3.doc

      While rendering it is not able to render elements which have the same name, once it has occurred previously in the tree. For e.g. Root/Personal_Information/Images does not show any children, while Root/Marketing_Information/Images show all children. The same happens with "Brochers". But those which come for the first time like 'Assets' are being displayed properly. After investigating the problem I found the problem is because of the non-unique element id (e.g <a href="#" id="BrochuresActuator" class="actuator">Brochures</a>
      <ul style="display: block;" id="BrochuresMenu" class="submenu">) .

        Activity

        Matt Raible added a comment -

        Fixed in CVS.


          People

          • Assignee:
            Matt Raible
            Reporter:
            Gaurav Kumar
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: